Hata: Veritabanı sunucusuna test bağlantısı başarısız oldu:

Diğer veritabanları ve SQL komutlarıyla ilgli sorularınızı sorabilirsiniz. Delphi tarafındaki sorularınızı lütfen Programlama forumunda sorunuz.
Cevapla
erdogan_ozkaya
Üye
Mesajlar: 806
Kayıt: 03 Eki 2007 01:00

Hata: Veritabanı sunucusuna test bağlantısı başarısız oldu:

Mesaj gönderen erdogan_ozkaya » 02 Şub 2015 11:11

ARKADAŞLAR BİR ŞEKİLDE BİR HATA YAPTIM NE YAPTIM ANLAYAMADIM AMA ARTIK VERİTABANI AÇAMIYORUM AŞAĞIDAKİ HATAYI ALIYORUM
YARDIMLARINIZI RİCA EDİYORUM TEŞEKKÜRLER

SUNUCU BİZE AİT WİNDOWS PLESK PANEL sürümü 12.0.18


Hata: Veritabanı sunucusuna test bağlantısı başarısız oldu:

mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file

Kullanıcı avatarı
hi_selamlar
Üye
Mesajlar: 522
Kayıt: 05 May 2005 02:24
Konum: DelphiTürkiye.COM

Re: Hata: Veritabanı sunucusuna test bağlantısı başarısız oldu:

Mesaj gönderen hi_selamlar » 18 Mar 2015 12:37

Herkes cahildir, bazi konularda.

erdogan_ozkaya
Üye
Mesajlar: 806
Kayıt: 03 Eki 2007 01:00

Re: Hata: Veritabanı sunucusuna test bağlantısı başarısız oldu:

Mesaj gönderen erdogan_ozkaya » 19 Mar 2015 10:31

arkadaş çok basit ve kolay bir yolu var,

sunucuda,
Adım 1. önce hizmetlerden mysql durdurum.

Adım 2. C:\Program Files (x86)\Parallels\Plesk\Databases\MySQL\data klasörün için de my.ini dosyası var aşağıdaki satırın (67 satır) altına aşağıdaki kodu ekleyin

Kod: Tümünü seç

skip-grant-tables
Adım 3. hizmetlerden mysql tekrar başlatın

Adım 4. çalıştıra CMD yazıp enter diyin ve buraya girin ( cd C:\Program Files (x86)\Parallels\Plesk\Databases\MySQL\bin\ )
sırasıyla

Adım 5. mysql> UPDATE mysql.user SET Password=PASSWORD(‘yeni şifre girin’) WHERE User=’root’;

Adım 6. mysql> FLUSH PRIVILEGES
Adım 7. mysql -u root mysql

Adım 8. C:\Program Files (x86)\Parallels\Plesk\Databases\MySQL\data klasörün için de my.ini dosyası var aşağıdaki satırın (67 satır) altına aşağıdaki kodu kaldırın

Kod: Tümünü seç

skip-grant-tables
Adım 9. mysql yeniden başlatın

Adım 10 MySQL şifrenizi. Plesk'ten güncelleyin

bu sorunu sunucuyu kiraladığım firma yeni sunucu vererek çözdü :)

Adım 8. satırını kaldırın 'skip-hibe-tablolar' my.ini dosya ve yeniden başlatma mysql

Kod: Tümünü seç

[client]

port=3306

[mysql] 
 
default-character-set=latin1


# SERVER SECTION
# ----------------------------------------------------------------------
#
# The following options will be read by the MySQL Server. Make sure that
# you have installed the server correctly (see above) so it reads this 
# file.
#
[mysqld]  
# The TCP/IP Port the MySQL Server will listen on
port=3306

Cevapla