Type Library App.Config sorunu

C# (C Sharp) veya Java ile ilgili konuları buraya yazabilirsiniz.
Cevapla
Kullanıcı avatarı
vkamadan
Kıdemli Üye
Mesajlar: 1935
Kayıt: 17 Mar 2004 03:52
Konum: Adapazarı
İletişim:

Type Library App.Config sorunu

Mesaj gönderen vkamadan » 03 May 2012 08:32

Merhabalar ,

Delphi ortamından SVC uzantılı .NET web servislerini kullanmam gerekti bunun için c# ta bir Type Library oluşturdum ve delphiden bu kitaplığa ulaştım içindeki basit medotları çalıştırmada sorun yok fakat SVC web servisine başvuran metodlar app.config içinde ilgili interface in başvurduğu bir endpoint bulunamadı gibi bir hata veriyor nette yaptığım araştırmalarda bu sorunun Type Library nin app.config dosyasını yükleyememesinden kaynaklandığını buldum, hatta çözüm olarak Type Library i kullanan ana projenin App.Config dosyasında TypeLibrary içindeki servis sınıflarının endpoint tanımlarının eklenmesi gerekir gibi sonuçlara ulaştım ancak ana uygulama delphi olduğu için böyle bir şansım yok, sonuç olarak sormak istediğim şu , Type Library içinde çalışma anında verdiğim konumdaki app.config dosyasını load etmesini sağlayabileceğim bir yapı mümkün mü ? Exe ler için mümkün olduğunu gördüm ama DLL içinde sonuç vermedi ilgili metodlar.
İyi çalışmalar.
Volkan KAMADAN
www.polisoft.com.tr

Kullanıcı avatarı
lazio
Moderator
Mesajlar: 1526
Kayıt: 11 Tem 2003 03:55
Konum: İstanbul
İletişim:

Re: Type Library App.Config sorunu

Mesaj gönderen lazio » 09 May 2012 01:18

Resim

..::|YeşilMavi|::..

Kullanıcı avatarı
vkamadan
Kıdemli Üye
Mesajlar: 1935
Kayıt: 17 Mar 2004 03:52
Konum: Adapazarı
İletişim:

Re: Type Library App.Config sorunu

Mesaj gönderen vkamadan » 09 May 2012 01:29

@lazio link için teşekkür ederim ,
eğer tecrübe ettiyseniz konuyu biraz açabilirmisiniz , DLL projesini relase için build ettiğimde dizinine DLL adını içeren "TGBServices.dll.config" böyle bir config dosyası oluşturuyor içeriği şöyle ;
bu dosyada nasıl bir değişikli yapmalıyım?

Kod: Tümünü seç

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <system.serviceModel>
        <bindings>
            <wsHttpBinding>
                <binding name="WSHttpBinding_ITGBServices" closeTimeout="00:01:00"
                    openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00"
                    bypassProxyOnLocal="false" transactionFlow="false" hostNameComparisonMode="StrongWildcard"
                    maxBufferPoolSize="524288" maxReceivedMessageSize="65536"
                    messageEncoding="Text" textEncoding="utf-8" useDefaultWebProxy="true"
                    allowCookies="false">
                    <readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384"
                        maxBytesPerRead="4096" maxNameTableCharCount="16384" />
                    <reliableSession ordered="true" inactivityTimeout="00:10:00"
                        enabled="false" />
                    <security mode="Message">
                        <transport clientCredentialType="Windows" proxyCredentialType="None"
                            realm="" />
                        <message clientCredentialType="UserName" negotiateServiceCredential="true"
                            algorithmSuite="Default" />
                    </security>
                </binding>
            </wsHttpBinding>
        </bindings>
        <client>
            <endpoint address="http://argetest.sanayi.gov.tr/_vti_bin/TGBService/TGBService.svc"
                                      behaviorConfiguration="TGBServiceProxyBehavior"
                binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_ITGBServices"
                contract="ServiceReference1.ITGBServices" name="WSHttpBinding_ITGBServices">
                <identity>
                    <certificate encodedValue="AwAAAAEAAAAUAAAAnWWxcNMZt5i084gA8p3LAX5yRGsgAAAAAQAAAOkCAAAwggLlMIIBzaADAgECAhBVIRTf7dOoi0kHORnzc5RrMA0GCSqGSIb3DQEBBQUAMBoxGDAWBgNVBAMTD1dNU3ZjLUFSR0VJSVMwMjAeFw0xMTA0MjAwODMzMjhaFw0yMTA0MTcwODMzMjhaMBoxGDAWBgNVBAMTD1dNU3ZjLUFSR0VJSVMwMjCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEBAKL8TfoGZUE4nB3tZ9FfKcqBkno+BZq9jqYoUChdw0TNswd5nMy+nGZBlOUhK4cFWi/0857vBpnCcUDKoRWcJpv59fp8UFWPful+WkxWOa74IU6XfQP9dGvE8D7c3UsbbStjrg0O5u/d6CSQxkJkC4WGcLdvFl2Qcf8j/zdfC3PDYyRkJbdelmNn6fSEgQ3r1wMFdLIAxz4fhDqrs8s3ZGil1ojnh3jDuffbXa5/XkikgjsiK4zBLMapWuHucNs1u+elYvMZGWwLEbUDtuy7z/v5/zog2rzn4DQsOVoWpuk6dpFHaTF/H5kbyIdbkN8JzIlGP/jErhZemRT45ixAowMCAwEAAaMnMCUwEwYDVR0lBAwwCgYIKwYBBQUHAwEwDgYDVR0PBAcDBQCwAAAAMA0GCSqGSIb3DQEBBQUAA4IBAQAGjIXfU/Mixay4D+7qpSgZcG28db4r3yYWph3z2R8MDjT9jGwsCy623hHARClTDcpuYZViYGexRvY8T7S5CiBwC5yHbyZNvPUPt2I7EUlkkaTf4Ji6GEXJ/sZNst7DeI3p7ik3xnCWnmdUlwjSwHzBC19vseRaXAuqSgb4f7RPi1JnmY1zVgDlfepym2ENlghdHNpcmzPqEW0/1go4wvDU7GWUsn43smDBKhM5mxtiYbfoXxRp9XbqBUCy6qLI0gqeNfD9slr2YXOXV/JCsetcgzQhrkIFAfPs7JH7WbdpLPw9KFl+z2GjQ64rVxa0iEk9osXKr8hT2/fPGZmbSuy2" />
                </identity>
            </endpoint>
        </client>
      <behaviors>
        <endpointBehaviors>
          <behavior name="TGBServiceProxyBehavior">
            <clientCredentials>
              <serviceCertificate>
                <authentication certificateValidationMode="None"/>
              </serviceCertificate>
            </clientCredentials>
          </behavior>
        </endpointBehaviors>
      </behaviors>

    </system.serviceModel>
</configuration>
Volkan KAMADAN
www.polisoft.com.tr

orhancc
Üye
Mesajlar: 585
Kayıt: 24 Ağu 2010 01:14
Konum: İstanbul / Kadıköy
İletişim:

Re: Type Library App.Config sorunu

Mesaj gönderen orhancc » 09 May 2012 04:23

Eğer servise localden erişebiliyorsan dışarıdan erişim için ayrıca ayar yapman gerekebilir. Dosyayı yükleyemiyor olsa servis hiç açılmaz. Şuraları inceleyebilirsin

http://blah.winsmarts.com/2008-4-Host_a ... t_way.aspx
http://msdn.microsoft.com/en-us/library/ms733766.aspx

Kullanıcı avatarı
lazio
Moderator
Mesajlar: 1526
Kayıt: 11 Tem 2003 03:55
Konum: İstanbul
İletişim:

Re: Type Library App.Config sorunu

Mesaj gönderen lazio » 14 May 2012 12:52

Normal şartlarda class library ler in app.config yada web.config dosyası olmaz, referance edildikleri exe yada web prolerinin konfigrasyon dosyalarını kullanılırlar..
Tabiki bi şekilde setting dosyası (xml olarak) eklenebilir ve ordaki parametreler okunabilir faka bu şuanda sizin işinize yaramaz, çünkü wcf servisine başlanmak istediğinizde kendisi otomatik olarak web yada app config inizi arayacaktır parametrelerini okumak için..
Anladığım kadarıyla sizin class library niz bir .net exe sine bağlanmamış, bu durumda wcf servisinin parametrelerini programatik olarak yönetebilirsiniz..
aşağıdaki linkte benzer bir örnek var..
http://stackoverflow.com/questions/9663 ... ss-setting
Resim

..::|YeşilMavi|::..

Kullanıcı avatarı
vkamadan
Kıdemli Üye
Mesajlar: 1935
Kayıt: 17 Mar 2004 03:52
Konum: Adapazarı
İletişim:

Re: Type Library App.Config sorunu

Mesaj gönderen vkamadan » 14 May 2012 01:59

@lazio bilgiler için teşekkür ederim ,
farklı bir yöntem ile sonuca vardım sayılır , WCF olmayan basit bit web servis uygulaması ile wcf servisleri çalıştırdım ve bu basit web servislere delphi ortamından da erişerek amacıma ulaştım ,fakat web servis uygulamasını test ortamından alıp firmamız bünyesinde bulunan win2008 işletim sistemli sunucunun IIS ine yüklediğimde bir türlü çalıştıramadım web.config te özel bir ayar durumu var mı ? webten edindiğim bilgiler doğrultusunda uygulamaya çalıştım ama çözüm henüz yok , mesela ben .NET Framework 3.5 de oluşturdum web servisi , bizim sunucua framework 4.0 var sıkıntı nedeni bu olabilir mi? geriye uyumluluk var mı?
Volkan KAMADAN
www.polisoft.com.tr

Kullanıcı avatarı
lazio
Moderator
Mesajlar: 1526
Kayıt: 11 Tem 2003 03:55
Konum: İstanbul
İletişim:

Re: Type Library App.Config sorunu

Mesaj gönderen lazio » 15 May 2012 10:32

Geriye uyumlulukla ilgili bir sıkıntı çıkmaz başka bir sorun vardır ama hatanın ne olduğunu bilmek lazım, bazen uygulama ile ilgili değilde server konfigrasyonu ile ilgili sorunlar çıkabiliyor IIS işin içindeyse..
Resim

..::|YeşilMavi|::..

Kullanıcı avatarı
vkamadan
Kıdemli Üye
Mesajlar: 1935
Kayıt: 17 Mar 2004 03:52
Konum: Adapazarı
İletişim:

Re: Type Library App.Config sorunu

Mesaj gönderen vkamadan » 15 May 2012 11:06

EVet sorunun IIS ile ilgili olduğunu düşünüyorum verdiği hata "ASMX" için ilişkilendirilmiş bir işleyici eşlemesi yok diyor ama oysaki var, bu konuda yoğunlaşacağım.

İyi çalışmalar.
Volkan KAMADAN
www.polisoft.com.tr

Kullanıcı avatarı
lazio
Moderator
Mesajlar: 1526
Kayıt: 11 Tem 2003 03:55
Konum: İstanbul
İletişim:

Re: Type Library App.Config sorunu

Mesaj gönderen lazio » 15 May 2012 12:45

browser dan localhost olarak asmx i çağırdığınız da mı alıyorsunuz hatayı yoksa debug ederken mi?
Resim

..::|YeşilMavi|::..

Kullanıcı avatarı
vkamadan
Kıdemli Üye
Mesajlar: 1935
Kayıt: 17 Mar 2004 03:52
Konum: Adapazarı
İletişim:

Re: Type Library App.Config sorunu

Mesaj gönderen vkamadan » 15 May 2012 01:26

debug ta sorun yok ,IIS üzerine atınca oluşluyor, .NET Framework 4.0 için uygulama havuzu oluşturdum, ilgili havuzu kullanan bir uygulama ekledim işleyici eşlemelerinde IIS i .NET desteği ile kurarken kendi ekleidği aspx, asmx eşlemeleri mevcut kendim bir eklenti yada düzenleme yapmadım, ama bu halde de asmx için işleyici eşlemesi bulunamadı uyarısı veriyor.
Volkan KAMADAN
www.polisoft.com.tr

orhancc
Üye
Mesajlar: 585
Kayıt: 24 Ağu 2010 01:14
Konum: İstanbul / Kadıköy
İletişim:

Re: Type Library App.Config sorunu

Mesaj gönderen orhancc » 16 May 2012 06:12

Aktif olarak kullandığım wcf servisi için çalışan ayarlar

Kod: Tümünü seç

  <system.serviceModel>
    <bindings>
      <wsHttpBinding>
        <binding name="TheBindingConfig">
          <security mode="None" />
        </binding>
      </wsHttpBinding>
    </bindings>

    <services>
      <service name="OutService.Service1">
        <host>
          <baseAddresses>
            <add baseAddress = "http://localhost:8000/Design_Time_Addresses/OutService/Service1/" />
          </baseAddresses>
        </host>
        <!-- Service Endpoints -->
        <!-- Unless fully qualified, address is relative to base address supplied above -->
        <endpoint
			address =""
			binding="wsHttpBinding"
			contract="OutService.IService1"
			bindingConfiguration="TheBindingConfig"
			>
          <!-- 
              Upon deployment, the following identity element should be removed or replaced to reflect the 
              identity under which the deployed service runs.  If removed, WCF will infer an appropriate identity 
              automatically.
          -->
          <identity>
            <dns value="localhost"/>
          </identity>
        </endpoint>
        <!-- Metadata Endpoints -->
        <!-- The Metadata Exchange endpoint is used by the service to describe itself to clients. -->
        <!-- This endpoint does not use a secure binding and should be secured or removed before deployment -->
        <endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange"/>
      </service>
    </services>
    <behaviors>
      <serviceBehaviors>
        <behavior>
          <!-- To avoid disclosing metadata information, 
          set the value below to false and remove the metadata endpoint above before deployment -->
          <serviceMetadata httpGetEnabled="True"/>
          <!-- To receive exception details in faults for debugging purposes, 
          set the value below to true.  Set to false before deployment 
          to avoid disclosing exception information -->
          <serviceDebug includeExceptionDetailInFaults="False" />
        </behavior>
      </serviceBehaviors>
    </behaviors>
  </system.serviceModel>
Servisteki olayları yakalamak için aşağıdaki ayarları eklersen daha net birşeyler görebilirsin
bin klasörünün içine wcf-traces.svclog isimli dosya oluşturacak

Kod: Tümünü seç

  <system.diagnostics>
    <sources>
      <source name="System.ServiceModel"
              switchValue="Information"
              propagateActivity="true">
        <listeners>
          <add name="ServiceModelTraceListener"
               type="System.Diagnostics.XmlWriterTraceListener, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"
               initializeData="wcf-traces.svclog"/>
        </listeners>
      </source>
    </sources>
  </system.diagnostics>

Kullanıcı avatarı
vkamadan
Kıdemli Üye
Mesajlar: 1935
Kayıt: 17 Mar 2004 03:52
Konum: Adapazarı
İletişim:

Re: Type Library App.Config sorunu

Mesaj gönderen vkamadan » 17 May 2012 07:57

@orhancc cevabın için teşekkürler ,
fakat benim projem WCF servis değil, SOAP servis ,bunu host etmeye çalışıyorum fakat ben sorunun halen IIS ile ilgili olduğunu düşünüyorum, çözünce paylaşacağım.
Volkan KAMADAN
www.polisoft.com.tr

Cevapla