Site açılırken şifre soruyor.

Delphi .net ve .net ile ilgili konuları buraya yazabilirsiniz.
Cevapla
deep_dream
Üye
Mesajlar: 33
Kayıt: 03 Nis 2007 12:57

Site açılırken şifre soruyor.

Mesaj gönderen deep_dream » 15 Haz 2008 01:15

Arkadaşlar, kendi bilgisayarımda deneme amaçlı küçük bir web sitesi kurdum, 1-2 gün normal çalıştı, ondan sonra bazı sayfaları açarken şifre sormaya başladı, sorduğu şifrede benim bilgisayarı açarken kullandığım şifre. Dikkat ettim bir sayfada yapıyor bunu ve o sayfada 8 tane resim var. 3 resimi yüklüyor 4. resim yüklenirken şifre soruyor, şifreyi doğru yazarsam sayfa yüklenmeye devam ediyor, doğru yazmazsam 4.resimi yüklemiyor diğer resimleri yüklüyor.
Sitenin adresi şu an için kimsede yok, hani dışarıdan müdehale edilme hacklanme gibi bir durum mümkün değil. Kendi çapımda deneme amaçlı uğraşıyorum. Sorun nedir sizce?

Kullanıcı avatarı
lazio
Moderator
Mesajlar: 1526
Kayıt: 11 Tem 2003 03:55
Konum: İstanbul
İletişim:

Re: Site açılırken şifre soruyor.

Mesaj gönderen lazio » 16 Haz 2008 02:33

webconfig de

Kod: Tümünü seç

<authentication mode="Forms">
olduğunu kontrol edin, resimlerin izinlerini kontrol edin.
Resim

..::|YeşilMavi|::..

deep_dream
Üye
Mesajlar: 33
Kayıt: 03 Nis 2007 12:57

Re: Site açılırken şifre soruyor.

Mesaj gönderen deep_dream » 16 Haz 2008 03:16

Hocam webconfig dosyasını notepad ile açıp baktım ama o satır yok.
<authentication mode="Windows"/>
Bu satır var. El ile bu satırın altına ekledim ancak hata verdi sizin dediğiniz satırı nasıl ve nereye eklerim?
Birde resimlerin izinleri dediğiniz olay nedir, pek iyi sayılmam net konusunda biraz daha açıklar mısınız?

Kullanıcı avatarı
lazio
Moderator
Mesajlar: 1526
Kayıt: 11 Tem 2003 03:55
Konum: İstanbul
İletişim:

Re: Site açılırken şifre soruyor.

Mesaj gönderen lazio » 16 Haz 2008 03:57

"Windows" yazan yere "Forms" yazman yeterli.

resimlere erişim izniyle alakalı ASPNET user ı yada Everyone yetkili olmalı
Resim

..::|YeşilMavi|::..

deep_dream
Üye
Mesajlar: 33
Kayıt: 03 Nis 2007 12:57

Re: Site açılırken şifre soruyor.

Mesaj gönderen deep_dream » 16 Haz 2008 10:25

Hocam cevap için çok teşekkür ederim. 8 resim olan sayfada artık şifre sormuyor ancak bu seferde anasayfa yüklenirken sormaya başladı. :roll:
Resimlerin üzerine sağ tık yaptığımda açılan menüden özelliklere tıklıyorum ve açılan pencerede güvenlik sekmesine giriş yapıyorum, oradaki yetkiler tam görünüyor tüm kullanıcılar için. Ancak sorun şu ki ASPNET kullanıcısı yok benim pc de en güzeli temiz bir format atıp tekrar denemek. Teşekkürler.

Cevapla