Ado Connection bağlantısı kayboluyor

Delphi'de kod yazma ile ilgili sorularınızı bu foruma yazabilirsiniz.
Cevapla
Kullanıcı avatarı
m_ekici
Kıdemli Üye
Mesajlar: 547
Kayıt: 11 Haz 2003 05:49
Konum: Adana
İletişim:

Ado Connection bağlantısı kayboluyor

Mesaj gönderen m_ekici » 28 Ara 2017 03:44

Merhaba arkadaşlar

son 15 gündür projelerimden herhangi birini açtığımda DataModul de bulunan AdoConnection la ilgili aşağıdaki hatayı veriyor. ve yanlışlıkla EVET i seçersem O component kayboluyor. Projede buna bağlı tüm tquery leri tekrar bağlamak zorunda kalıyorum. HAYIR ı seçip projeyi kapatıp tekrar açıyorum bazen hatayı tekrarlıyor bazen de hata vermeden devam ediyor. Bu neden olur?

Field DBF.ConnectionII does not have a corresponding component. Remove the declaration?

ertank
Üye
Mesajlar: 1108
Kayıt: 11 Eyl 2015 11:45

Re: Ado Connection bağlantısı kayboluyor

Mesaj gönderen ertank » 28 Ara 2017 11:11

Embarcadero sorunuza aşağıdaki gibi bir cevap vermiş:
"The first section of your form's class declaration is reserved for use by the Form Designer.
To declare your own fields and methods, place them in a separate public, private, or protected section.
This error usually occurs when the form binary file (.DFM) is not synchronized with the class declaration, meaning that a component on the form does not have a corresponding field in the class.
This error occurs if you load the binary form file (.DFM) into the Code Editor and delete or rename one or more components."

Özetle;
- Formun ilk class tanımlarının içinde manuel değişiklik yapmayın. Bu kısım "Form Designer" tarafından kullanılır
- Kendi alan ve metodlarınızı public, private veya protected bölümlerinde yapın
- Bu hata genellikle form "binary" dosyası (DFM dosyaları binary formatta kaydedilebiliyor) class tanımı ile senkronize olmadığında oluşur. Yani form üzerine yerleştirmiş olduğunuz bileşen Form class tanımında bulunamaz ise.
- Bu hata ayrıca DFM dosyasını kaynak kod editörü içinde açıp içinden bileşen tanımı silinir ise de gerçekleşebiliyor.

Konu ile ilgili aşağıdaki diğer bağlantıları da inceleyebilirsiniz:
http://www.delphigroups.info/2/ad/304526.html
https://www.experts-exchange.com/questi ... onent.html
viewtopic.php?t=32559

Kullanıcı avatarı
m_ekici
Kıdemli Üye
Mesajlar: 547
Kayıt: 11 Haz 2003 05:49
Konum: Adana
İletişim:

Re: Ado Connection bağlantısı kayboluyor

Mesaj gönderen m_ekici » 29 Ara 2017 01:32

tşk. Bunu GExperts yapar mı?

ertank
Üye
Mesajlar: 1108
Kayıt: 11 Eyl 2015 11:45

Re: Ado Connection bağlantısı kayboluyor

Mesaj gönderen ertank » 29 Ara 2017 02:12

GExperts kullanmıyorum. Son gördüğümde "experimantal" (deneysel) ifadesini kullanıyorlardı. Günümüzde artık normal versiyon olup deneysellikten çıktı mı bilgim yok.
Artık normal sürüm olarak yayınlanmış olsa dahi sorunuza yuvarlak bir cevap olarak "Herhangi bir uygulamanın içinde hata "bug" olabilir" diyebilirim.

Kullanıcı avatarı
m_ekici
Kıdemli Üye
Mesajlar: 547
Kayıt: 11 Haz 2003 05:49
Konum: Adana
İletişim:

Re: Ado Connection bağlantısı kayboluyor

Mesaj gönderen m_ekici » 13 Oca 2018 12:44

Her projeyi açtığımda bu sorun tekrarlıyor. sürekli ayar yapmaktan bıktım.
hata veren formu (DataModul) ü 2-3 projede ortak kullanıyorum. Muhtemelen bundan yapıyor.
XE2 de aynı şekilde çalıştığım dosyalar var, hiç problem yok.
10.2 çıldırtacak.

ertank
Üye
Mesajlar: 1108
Kayıt: 11 Eyl 2015 11:45

Re: Ado Connection bağlantısı kayboluyor

Mesaj gönderen ertank » 13 Oca 2018 02:47

Sadece bir projede mi hata veriyor? Hata veren modülü dfm ve pas dosyası olarak paylaşmanız mümkün mü?

Cevapla