[Çözüldü] Webbrowser Flash videolar gösterilemiyor

Delphi'de kod yazma ile ilgili sorularınızı bu foruma yazabilirsiniz.
Cevapla
Lord_Ares
Üye
Mesajlar: 997
Kayıt: 15 Eki 2006 03:33
Konum: Çorlu

[Çözüldü] Webbrowser Flash videolar gösterilemiyor

Mesaj gönderen Lord_Ares » 03 Eki 2017 12:39

Webbrowser ile bir sayfadaki flash videoları görüntüleyemiyorum. Gerekli activex ve flashlar yüklü olmasına rağmen delphi webbrowser flash failed to load yazıyor. Explorer ile açabiliyorum.
En son Lord_Ares tarafından 05 Eki 2017 06:32 tarihinde düzenlendi, toplamda 1 kere düzenlendi.

ertank
Üye
Mesajlar: 835
Kayıt: 11 Eyl 2015 11:45

Re: Webbrowser Flash videolar gösterilemiyor

Mesaj gönderen ertank » 03 Eki 2017 08:45

Örnek bir proje hazırlayıp paylaşabilir misiniz?

Lord_Ares
Üye
Mesajlar: 997
Kayıt: 15 Eki 2006 03:33
Konum: Çorlu

Re: Webbrowser Flash videolar gösterilemiyor

Mesaj gönderen Lord_Ares » 04 Eki 2017 01:38

Webbrowser ile https://tombalalive.com/login siteye açmaya kalktığımda aldığım hata aşağıdaki resimdeki gibi flash plugin failed to load hatası..
Amacım ise sitedeki sadece video kısmını formuma eklemekti. Fakat Webbrowserda siteyi görüntüleyemediğim için daha olay başında gitti..
Denediğim yöntemler ise ,
1) webbrowserın document mod ayarını değiştirip denedim değişen birşey olmadı. Aynı hatayı almaya devam ettim.
2) Sayfanın kaynak kodunu webbrowser ile bastırıp göstermeye çalıştım sayfa hiç yüklenemedi..
3) Arka planda Explorer create edip webbrowser ile sayfayı tekrar açtım. Belki eklentileri aktif ederim diye fakat işe yaramadı
4) Mrmarmanın tamda konuyla alakalı iki güzel bir cevabı formumuzda var. Onlarıda denedim ama malesef sonuç aynı.
viewtopic.php?f=2&t=34133&start=15
viewtopic.php?f=2&t=34059&start=15

Kod: Tümünü seç

procedure TForm1.BitBtn1Click(Sender: TObject);
Var
  XIEpp : OleVariant;
begin
  if (VarIsEmpty(xIEpp)) then
  begin
    xIEpp := CreateOleObject('InternetExplorer.Application');
    WebBrowser1.Silent := True;
    WebBrowser1.Navigate('https://tombalalive.com/login');
    xIEpp.Quit;
    xIEpp := UnAssigned;
  end;
end;

Youtube gibi sitelerde sorunsuz açabiliyorum. Bunda neden olmadığını anlamış değilim...
Delphi Xe10 berlin ile windows8 windows7 iki farklı bilgisayarda denedim sonuç değişmedi..
Resim

ertank
Üye
Mesajlar: 835
Kayıt: 11 Eyl 2015 11:45

Re: Webbrowser Flash videolar gösterilemiyor

Mesaj gönderen ertank » 04 Eki 2017 07:58

Merhaba,

Microsoft firması Internet Explorer ile ilgili programcılar için teknik detay paylaşmıyor. Bu noktada sorun bir yanıt beklenmesi mi? Bir nesne oluşturulmadı mı? Bir değişken değeri değiştirilmesi mi? Maalesef belli değil. Çözümü pek mümkün gözükmüyor.

Lord_Ares
Üye
Mesajlar: 997
Kayıt: 15 Eki 2006 03:33
Konum: Çorlu

Re: Webbrowser Flash videolar gösterilemiyor

Mesaj gönderen Lord_Ares » 04 Eki 2017 11:10

Webbrowser gereken projeler almayalım diyeceğim ama malum devir internet devri onsuzda birşey olmuyor.. Kahretsin çözümsüz kaldık..

Lord_Ares
Üye
Mesajlar: 997
Kayıt: 15 Eki 2006 03:33
Konum: Çorlu

Re: Webbrowser Flash videolar gösterilemiyor

Mesaj gönderen Lord_Ares » 05 Eki 2017 09:55

Sanki sorun farklı bir yerde. Yani webbrowser eklenti için izin veremiyorum sanırım. Neden derseniz , yeni bir paylaşım gördüm bunu daha önce çalıştıran olmuş. Aşağıdaki html kod ile jwplayerı Mrmarman üstadımız browserda göstermiş. Bende niye olmuyor anlamış değilim. 3 farklı işletim sistemine sahip bilgisayarda denedim. Delphi de Webbrowser için activex enabled gibi bir şey varmı ki ?

MrMarman örneği viewtopic.php?f=2&t=34133&sid=e8ce8fa06 ... a&start=15

Kod: Tümünü seç

<script src="http://mtv.com.lb/Player/485/jwplayer.js" type="text/javascript"></script>
<script type="text/javascript">
//<![CDATA[
jwplayer.key = "OLt0hutFdsI99VbUahuSZ4tiX8eM+DK9W1bqRw==";
//]]>
</script>
<br />
<div id="player_7246">
</div>
<script type="text/javascript">
jwplayer('player_7246').setup({
file: "rtmp://37.77.2.234:1935/redirect/live",
width: "100%",
height: "100%",
primary: "flash",
image: "",
title: " [ARMAN TV için TIKLAYINIZ]",
abouttext: 'Web TV',
link: 'http://www.delphiturkiye.com/forum',
autostart: "false",
logo: {
file: "armanlogo.png",
link: "http://www.delphiturkiye.com/forum"
}
});
</script>

Kod: Tümünü seç

procedure TForm1.BitBtn1Click(Sender: TObject);
begin
  WebBrowser1.Silent := True;
  WebBrowser1.Navigate( 'http://aktuelkamera.org/arman/a/b.html' );
end;

Sonuç
Resim

ertank
Üye
Mesajlar: 835
Kayıt: 11 Eyl 2015 11:45

Re: Webbrowser Flash videolar gösterilemiyor

Mesaj gönderen ertank » 05 Eki 2017 10:31

Bulduğunuz örnek hangi yıla ait?

İnternet Explorer ve JwPlayer sürümleri sizin denemelerinizdekiler ile aynı mı?

Neden sorunun WebBrowser tarafında olduğunu düşünüyorsunuz? WebBrowser arka planda microsoft tarafından sağlanan bir bileşen dir. Daha önce bahsettiğim gibi teknik bilgisi detaylı paylaşılmaz. Dolayısıyla sorun aslında microsoft tarafında ancak ne olduğu belli değil. Kendilerince güvenlik adına bazı sınırlamalar getirmiş olabilirler. Belki sadece bir "bug" ancak bu durumda dahi çözümü yine Microsoft tarafından yapılması gereken bir bug.

Lord_Ares
Üye
Mesajlar: 997
Kayıt: 15 Eki 2006 03:33
Konum: Çorlu

Re: Webbrowser Flash videolar gösterilemiyor

Mesaj gönderen Lord_Ares » 05 Eki 2017 12:31

2 yıl öncesine ait bir örnek evet sürümlerin yapısını incelediğimde farklılık var. Sorunun onda olduğunu bana düşündüren iki şey oldu. (Yanılıyor olabilirim sadece fikir ..)
adobe bileşenler olmayan temiz bir windows7 işletim sistemi kurup explorer ve chrome tarayıcıları ile ilgili siteyi açtığımda flash eklentilerine gerekli izni vermezsem resimde gösterdiğim Flash plugin failed to load hatasını alıyorum. İzin verirsem sorunsuz çalışıyor. Acaba Twebbrowserda da aynı şeyi yapıp izin verebilsek çalışırmı ?
İkincisi ise canlı yayın yapan başka siteleri açmayı denedim site içeriğinde java , flash gibi nesneler kullananan sitelerin çoğunu düzgün görüntüleyemedi. Videoyu oynatamadı peki ya diğerlerini neden düzgün görüntüleyemedi diye düşünününce :)))

ertank
Üye
Mesajlar: 835
Kayıt: 11 Eyl 2015 11:45

Re: Webbrowser Flash videolar gösterilemiyor

Mesaj gönderen ertank » 05 Eki 2017 03:58

Lord_Ares yazdı:
05 Eki 2017 12:31
Acaba Twebbrowserda da aynı şeyi yapıp izin verebilsek çalışırmı ?
TWebBrowser içinde herhangi bir değişiklik/eklenti yapamazsınız.

Lord_Ares
Üye
Mesajlar: 997
Kayıt: 15 Eki 2006 03:33
Konum: Çorlu

Re: Webbrowser Flash videolar gösterilemiyor

Mesaj gönderen Lord_Ares » 05 Eki 2017 06:31

Hocam sorun çözüldü emeğine sağlık. Problem biraz daha farklı çıktı. Sayfanın Html kodunda görüldüki İki ayrı stream var.Safari, android ve firefox için m3u diğer browserlar için java player seçilmiş. Twebbrowserda gösterebilmek için clapper ı içeren bir html hazırlayıp twebbrowsera navigate etmek gerekiyormuş. ikinci bir yol ise Vlc activex kullanmak gerekiyormuş.
Sorunu çözen QuAdr arkadaşımada çok teşekkür ediyorum.

Cevapla