Quickreportta access violation hatası

Delphi'de kod yazma ile ilgili sorularınızı bu foruma yazabilirsiniz.
Cevapla
sonuncusado
Üye
Mesajlar: 37
Kayıt: 13 May 2005 02:36

Quickreportta access violation hatası

Mesaj gönderen sonuncusado » 21 Eki 2005 09:57

mrb arkadaslar,
benim sorunum çalışmış olduğum projedeki quickreport formlarının show edilmesini istediğimde ortaya çıkıyor. bu sorun bütün formlarda omuyor bazısında.. forumda araştırdım ama tatmin edici bir cevap alamadım. yazıcı yok bilgisayarda, query ye baktım hic bir sorun yok, hatta açılan formda 3 tane quickreport var ikisi acılırken genle toplamı gosterecek raporun acılmadıgı bi yer var bu dedigim kontrolleri burası ici nyaptım.
quickreportu yeniden yukleyip kaldırdım. yani anlıyacagınız herseyi yaptım. çıdırmak üzereyim... yardmlarınızı bekliyorum.

ii calısmalar

sonuncusado
Üye
Mesajlar: 37
Kayıt: 13 May 2005 02:36

Mesaj gönderen sonuncusado » 21 Eki 2005 10:18

tekrardan merhaba.

arkadaslar az once solemistim ama tekrardan su ayrıntıyı belirtmek istiyorum..

Kod: Tümünü seç

if fmasraftoplam.Checktoplam.Checked then
QRCompositeReport1.Reports.Add(QuickRep2)
else QRCompositeReport1.Reports.Add(QuickRep1);
QRCompositeReport1.Reports.Add(QuickRep3);
bu codda QuickRep3 create edilirken bir sorun cıkıyor..... Bu neden olabilir gerçekten bunu cok acil ama cok acil orenmem lazım. yardımlarınızı bekliyorummm

sonuncusado
Üye
Mesajlar: 37
Kayıt: 13 May 2005 02:36

Mesaj gönderen sonuncusado » 21 Eki 2005 11:07

yok mu bu işten anlayan :cry:

Kullanıcı avatarı
aslangeri
Moderator
Mesajlar: 4319
Kayıt: 26 Ara 2003 04:19
Konum: Ankara
İletişim:

Mesaj gönderen aslangeri » 21 Eki 2005 12:10

s.a.
quickrep 3 ü sil. quickrep2 yi kopyalayıp üzerinde değişiklik yap.
ama değişiklikleri adım adım yapıp test edersen daha sağlıklı olur.

bide sistemde yazıcı yok demişsin onla ilgili bi şey olabilir
sisteme bi tane yazıcı yükleyip dene...

kolay gelsin.
Duyduğun Şeylerin Söylediklerim Olduğuna Eminim Ama
Anladığın Şeylerin Anlatmak İstediklerim Olduğuna Emin Değilim

Mikdad
Üye
Mesajlar: 11
Kayıt: 15 Eki 2005 02:00
İletişim:

Merhaba

Mesaj gönderen Mikdad » 21 Eki 2005 12:11

kardeş Sen Qreportu kullanıyorsunda çalıştığın makinada yazıcı yoksada yazıcı ekle çünkü bu tür sorunları verir. Ek olarak 2 3 qrep kullandım diyorsun bunu aynı form üstündemi kullandın yoksa herbiri başka formdamı bunun etkisi çok fazla . yazdığın kodlarda bir hata yok onu da belirteyim teknik bir sorun olması gerekiyor

sonuncusado
Üye
Mesajlar: 37
Kayıt: 13 May 2005 02:36

Mesaj gönderen sonuncusado » 21 Eki 2005 12:14

arkadaslar az once yeni bir topic daha actım. orada bahsettigim sey ise sorunun kaynagının bendeki bir queryden kaynaklandıgına inanmam oldu....dediklerinizi deneyecegim...

sonuncusado
Üye
Mesajlar: 37
Kayıt: 13 May 2005 02:36

Mesaj gönderen sonuncusado » 21 Eki 2005 12:17

ahh cok ozur diliyorum yazıcı varmısssss.. bu benim yeni calısmaya basladıgım bir yerde ağ uzerinde yazıcı varmıs simdi ne yapmam gerek..

Cevapla